Phone support
Incident Report for Enom
Resolved
Our phone system has remained stable since our last update, and our vendor has cleared the upstream issue. Thanks for hanging in there!
Posted 4 months ago. Jul 02, 2019 - 08:54 PDT
Monitoring
Our phone system is showing significant improvement, and our upstream vendor continues to monitor the situation on their end.
Posted 4 months ago. Jul 02, 2019 - 07:30 PDT
Investigating
You may not be able to reach our Support team via phone at this time or there may be intermittent phone connection issues due to an outage with one of our vendor partners. We're on it and will keep you updated.
Posted 4 months ago. Jul 02, 2019 - 07:12 PDT
This incident affected: Customer Support.