HostedEmail - Webmail Degraded

Incident Report for Enom

Resolved

This issue has been resolved.

Incident Start Time: 03-09-2023 07:04:00 PT
Incident End Time: 03-09-2023 07:24:00 PT
Total Duration:20 minutes
Posted Mar 09, 2023 - 09:07 PST

Monitoring

Our team has identified and resolved the issue. We will continue to monitor for further webmail login issues.
Posted Mar 09, 2023 - 07:35 PST

Investigating

We are currently investigating service issues with the Hosted Email platform. Users may be unable to access their accounts via webmail at this time.

Thank you for your patience.
Posted Mar 09, 2023 - 07:23 PST
This incident affected: Basic Email Service.