Geotrust SSL Delays
Incident Report for Enom
Resolved
DigiCert has confirmed that the order delays they were experiencing have been resolved. This was due to a syncing issue on their end.
Posted Mar 19, 2019 - 08:07 PDT
Investigating
We have reports of SSL certificates order delays. Once an order has been placed and has completed, you may notice a delay in receiving the email confirmation.
DigiCert has confirmed this is only affecting Geotrust and RapidSSL orders and are investigating the problem.

Please note the delays can vary, and they are working towards a resolution.
Posted Mar 18, 2019 - 09:36 PDT
This incident affected: SSL Certificates.