Enom
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 20:27 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 18:09 PDT
Update
Our team is continuing to implement a fix. Customers may be able to access their account but may still see slowness as well as not be able to make purchases or updates to their domains. We hope to have a resolution soon and will continue to post updates here.
Posted Jul 19, 2024 - 13:21 PDT
Update
Our team is continuing to implement a full fix for the intermittent issues and slowness with domain management and API caused by the global CrowdStrike outage. We appreciate your continued patience as we continue to work on a fix. We will continue to provide further updates here.
Posted Jul 19, 2024 - 10:57 PDT
Update
We are still working on the resolution for the intermittent issues with accessing and managing domains through Enom accounts and the API due to the ongoing global CrowdStrike outage. Our Customer Support Team continues to be affected as well. We appreciate your understanding and patience as we continue to address this situation. Updates will be posted here.
Posted Jul 19, 2024 - 06:55 PDT
Update
We are currently experiencing intermittent issues with accessing and managing domains through Enom accounts and the API due to the ongoing global CrowdStrike outage. This is also impacting our Customer Support Team. Our team is actively working to resolve this situation. We will continue to provide updates here. Thank you for your understanding and patience.
Posted Jul 19, 2024 - 05:38 PDT
Update
Our developers found the main problem and are working on a fix. Our support systems are also affected by this issue right now.
Posted Jul 19, 2024 - 05:12 PDT
Identified
Our developers have identified the root issue and are currently investigating a possible fix.
Posted Jul 19, 2024 - 02:22 PDT
Investigating
We are receiving reports of issues with being able to login to Enom accounts and accessing and managing domains from within Enom accounts or with API.

Our developers are currently investigating.
Posted Jul 18, 2024 - 22:39 PDT
This incident affected: Enom.com (Website, Domain Management) and API, Customer Support.