DNS Update and Resolution Issues
Incident Report for Enom
Postmortem

Summary: On April 26th, 2024 starting at 8:48 am PDT, Enom began receiving reports from customers regarding a DNS issue affecting CNAME records. Upon investigation we discovered the cause was an incorrect configuration pushed to the Enom DNS service, which disabled support for ALIAS records. 

The initial Status Update at 8:59 am PDT stated this change was intentional and that it would remain in place permanently. This statement was incorrect and the post was retracted. 

Client Impact: A small subset of Enom clients were impacted. Only client DNS zones using CNAME records pointed at the domain root were affected, if and when that particular record was queried at the time. 

Remediation: The issue was resolved by reverting the configuration change on the Enom DNS service, re-enabling support for ALIAS records. The change was reverted and fully tested around 2:05 pm PDT.

Posted Apr 26, 2024 - 15:57 PDT

Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 10:47 PDT
Monitoring
The issue has been resolved, we will continue to monitor to make sure there are no further issues.
Posted Apr 26, 2024 - 09:53 PDT
Investigating
We are currently investigating an issue where customers are seeing DNS resolution as well as propagation issues on our system. Our engineering team is currently investigating and we hope to have a solution soon
Posted Apr 26, 2024 - 08:59 PDT
This incident affected: DNS Service.