Webmail Issues
Incident Report for Enom
Resolved
This issue has been resolved.
Posted Mar 01, 2021 - 13:58 PST
Monitoring
Our team was able to identify and resolve the issue. We will continue to monitor for further reports.
Posted Mar 01, 2021 - 13:33 PST
Investigating
Customers may have issues accessing their Enom hosted emails at this time. During this time, users may have issues logging in and accessing their email. We thank you for your patience as our team further investigates this case.
Posted Mar 01, 2021 - 13:05 PST
This incident affected: Basic Email Service.