Inbound Mail Delays, Slowness, IMAP Connection Failures
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 09:26 PST
Update
We are continuing to investigate this issue, and will post any updates as they are available.
Posted Feb 20, 2024 - 09:02 PST
Investigating
We are currently experiencing inbound mail delays, slowness, and IMAP connection failures on Cluster A. Our engineering team is investigating the issue.

We will provide an update once we have additional information.
Posted Feb 20, 2024 - 08:32 PST
This incident affected: Basic Email Service.