HostedEmail - Degraded
Incident Report for Enom
Resolved
Our team fixed the issues and tests have been done, all services are functional and working as expected now.
Posted Nov 14, 2024 - 04:00 PST
Update
We are continuing to investigate this issue.
Posted Nov 13, 2024 - 18:49 PST
Investigating
We are currently experiencing unplanned maintenance for our email service. Some inboxes will be inaccessible until work is completed.
Posted Nov 13, 2024 - 18:09 PST
This incident affected: Basic Email Service.