Domain Management and WHOIS
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Mar 20, 2019 - 08:07 PDT
Monitoring
Our operations team has been able to address the issue and service is functioning as it should. We will continue to monitor the case.
Posted Mar 20, 2019 - 07:02 PDT
Identified
Users may experience slowness while using domain management control panels and WHOIS service. This would affect registering/renewing/transferring domains along with WHOIS lookups.

Our Operations team is already working on this, and we will provide an update as soon as possible.
Posted Mar 20, 2019 - 05:55 PDT
This incident affected: Enom.com (Website, Domain Search, Domain Purchase, Domain Management) and API.