Hosted Email
Incident Report for Enom
Resolved
For a period of 5 hours, customers may have seen service degradation causing delays with inbound mail and/or authentication issues when attempting to connect via Webmail, IMAP, or POP. Our operations team was able to resolve the issue and full service has been restored.

Incident Start Time: 07-16-2020 20:45:00
Incident End Time:07-17-2020 01:45:00
Total Duration: 5 hours.
Posted Jul 17, 2020 - 05:02 PDT
Investigating
Degradation of service
Posted Jul 17, 2020 - 00:24 PDT
This incident affected: Basic Email Service.