Account Password Reset Delays
Incident Report for Enom
Resolved
This issue has been fully resolved.

We appreciate your patience.
Posted Nov 27, 2019 - 18:53 PST
Monitoring
A fix has been implemented by our team and we our presently monitoring the results.

Thank you for your continued patience.
Posted Nov 27, 2019 - 16:58 PST
Investigating
We are investigating reports of password reset emails being delayed or in some cases not sent at all. We appreciate your patience while this issue is ongoing.
Posted Nov 27, 2019 - 13:53 PST