.WS Registry Connection Issues
Incident Report for Enom
Resolved
This case has been resolved.
Posted Mar 05, 2021 - 10:14 PST
Investigating
We are currently seeing registry connection issues for .WS. During this time customers may have issues with registrations, renewals, and lookups. We hope to have a fix soon.
Posted Mar 05, 2021 - 07:11 PST
This incident affected: Domain Services (Other ccTLDs).