DNS - Host Records
Incident Report for Enom
Resolved
The DNS host record update delays are now resolved. Thank you.
Posted Feb 20, 2019 - 03:53 PST
Update
Our operations team is still monitoring this issue and working on a resolution as quickly as possible. We apologize for any delay your experiencing. We will continue to provide you with updates as they become available.
Posted Feb 20, 2019 - 03:01 PST
Identified
We are currently experiencing an incident affecting changes to Host Records.

Propagation of new host record entries on Enom's DNS Servers will be delayed. We are monitoring this issue and will update you with any new information as it becomes available.
Posted Feb 19, 2019 - 20:56 PST
This incident affected: DNS Service.