DNS Host Record update Delays
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 17:56 PDT
Investigating
We are currently experiencing delays in Host record propagation when using Enom's Nameservers. Our Engineering team has been engaged to investigate and work on a fix. We thank you for your patience on this case.
Posted Aug 11, 2022 - 16:49 PDT
This incident affected: DNS Service.