Enom Email Services
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 17:41 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2020 - 16:45 PDT
Identified
Our team has identified the issue we are seeing with our Email Services and a fix is being implemented.
Posted Jun 18, 2020 - 16:21 PDT
Update
Our team is continuing to investigate the issues we are seeing with our email services.

At present users may experience the following:

-Delays in mail.enom.com loading or not loading at all
-Being unable to login to your Enom email services

We will provide updates as they become available.

Thank you for your patience.
Posted Jun 18, 2020 - 15:24 PDT
Investigating
We are currently investigating reports of customers seeing delays in accessing their email services. We are primarily seeing this through mail.enom.com however, other mail clients may experience delays as well.

We will provide updates as they become available.
Posted Jun 18, 2020 - 14:31 PDT
This incident affected: Basic Email Service.