Email Services
Incident Report for Enom
Resolved
We can confirm services are fully operational and stabilized completely. This incident is now resolved.
Posted Sep 17, 2021 - 10:35 PDT
Monitoring
We have initiated measures to restore service for our cluster A users, we will be continuing to monitor to ensure stability. As of now users should be able to log back into their webmail for use.
Posted Sep 17, 2021 - 09:55 PDT
Investigating
We are currently investigating a login issue for a small set of customers on Cluster A (Webmail, POP, IMAP).

The engineering team has been engaged and is currently investigating the cause of this issue.
Posted Sep 17, 2021 - 09:11 PDT
This incident affected: Basic Email Service.