Nominet Registry Connections
Incident Report for Enom
Resolved
Nominet's connection has been restored, and all Nominet TLD's are functioning as expected.
Posted Nov 13, 2019 - 00:06 PST
Identified
We are currently experiencing connection issues with the Nominet registry. Our operations team has contacted the registry and determined this is due to unannounced maintenance.

This affects registrations, renewals, and management of all Nominet managed domains. Existing domains will continue to resolve normally

For a list of affected domains, please see our TLD list at https://help.enom.com/hc/en-us/articles/115001060492-TLD-Reference-Chart
Posted Nov 12, 2019 - 22:43 PST
This incident affected: Domain Services (Core ccTLDs, Other gTLDs).