.tm Registry
Incident Report for Enom
Resolved
Please reach out to our support team if you need assistance with renewing a .TM domain:

https://help.enom.com
Posted Nov 23, 2019 - 05:11 PST
Monitoring
We've resolved the issues with renewals and registrations of .TM domains and will continue to monitor.
Posted Nov 22, 2019 - 12:59 PST
Identified
We are currently looking into an issue that may affect the renewals and registrations of .tm domains. We appreciate your patience with this matter while we get this issue resolved.
Posted Nov 22, 2019 - 11:01 PST
This incident affected: Domain Services (Other ccTLDs).