.jobs Domain Management Issue
Incident Report for Enom
Resolved
We now know what's causing the problem for .jobs TLD and will be reaching out to the effected customers to assist.

If you are still experiencing issues, please don't hesitate to contact us!
Posted Oct 09, 2018 - 06:46 PDT
Investigating
We are currently looking into an issue with the .jobs TLD where these domains are not showing up within Enom accounts affecting domain management and updates. The Dev team is currently looking to see what is causing this issue and what can be done to resolve.

Thank you for your patience on this matter.
Posted Oct 04, 2018 - 11:26 PDT
This incident affected: Domain Services (Other gTLDs).