.NU Registry Connections
Incident Report for Enom
Resolved
Connections to the .NU registry has been restored. The registry has not confirmed the cause, but services have been restored.
Posted 3 months ago. Mar 04, 2019 - 07:01 PST
Investigating
We are currently experiencing connection issues with the .NU registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .NU domains. Existing domains will continue to resolve normally.
Posted 3 months ago. Mar 04, 2019 - 06:48 PST
This incident affected: Domain Services (Other ccTLDs).