Afilias Registry
Incident Report for Enom
Resolved
This issue has been resolved.
Posted Feb 25, 2021 - 03:39 PST
Update
We are experiencing Connection issues with Aflias Registry services.
This is affecting the below TLDs:

.asia
.mobi
.info
.org
.pro
.xxx
.me
.archi
.bz

During this outage, the below will be degraded or unavailable:

Registrations
Renewals
Transfers
Contact info changes
DNS server changes

We have reached out to Afilias for more information. We will provide a status update as soon as possible.
Posted Feb 25, 2021 - 02:26 PST
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted Feb 25, 2021 - 02:12 PST
This incident affected: Domain Services (Core gTLDs, Other gTLDs, Other ccTLDs).