Purchase Delays
Incident Report for Enom
Resolved
The fix implemented for our order processing delays was effective, and the backlog of unprocessed orders has now fully cleared. We're back up and running with regular order turnaround times. Thanks for bearing with us!
Posted 3 months ago. Apr 03, 2019 - 06:00 PDT
Update
The issue with orders being delayed has been identified and a fix has been deployed.

We are continuing to work through the backlog of orders.

Thank you for your continued patience.
Posted 3 months ago. Apr 02, 2019 - 17:01 PDT
Update
We are still working to make sure that this issue is resolved.

We appreciate your continued patience on this matter.
Posted 3 months ago. Apr 02, 2019 - 13:08 PDT
Identified
We have identified the issue and are working towards a resolution. We are processing the backlog of orders and thank you for your patience.
Posted 3 months ago. Apr 02, 2019 - 08:31 PDT
Investigating
We are investigating reports of purchase delays. We continue to manually approve these as they come through. We appreciate your patience while we work towards a resolution.
Posted 3 months ago. Apr 02, 2019 - 08:20 PDT
This incident affected: Enom.com (Domain Purchase).