CO.ZA ZACR Registry Connections
Incident Report for Enom
Resolved
Apologies, this was posted in error.
Posted 26 days ago. Jul 23, 2019 - 23:48 PDT
Investigating
We are currently experiencing connection issues with the ZACR registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of domains. Existing domains will continue to resolve normally
Posted 26 days ago. Jul 23, 2019 - 23:35 PDT
This incident affected: Domain Services (Core ccTLDs).