.LA, .GS, .IT Registry
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 05:48 PST
Investigating
We are experiencing issues with our connection to the .LA, .GS, .IT Registry

During this time you may experience issues with:

Registration
Renewals
Transfers
Contact Management
DNS server changes

We will provide updates as they become available.
Posted Mar 02, 2021 - 20:27 PST