Enom Phone Support Issue
Incident Report for Enom
Resolved
Everything with our phone support service should be good to go now. Thank you so much for bearing with us through this.
Posted Nov 05, 2018 - 09:32 PST
Monitoring
The phone service should be running as normal now but we are keeping it open for a bit just to keep an eye on things. Our upstream provider is continuing to monitor the progress from their end.
Posted Nov 05, 2018 - 09:21 PST
Investigating
We are investigating an intermittent issue related to calls being routed to our phone support line. This may affect those trying to reach Enom by phone at this time.

Enom Support can still be reached via live chat on our website and by email at customercare@enom.com at this time. We are actively working to resolve this issue, thank you for your patience.
Posted Nov 05, 2018 - 08:33 PST
This incident affected: Customer Support.