Sectigo SSL - CSR errors
Incident Report for Enom
Resolved
We are no longer seeing issues with our SSL certificates. Please reach out to live support if you experience any further difficulties.
Posted Oct 04, 2022 - 19:47 PDT
Monitoring
While we await official confirmation from Sectigo, SSL order processing has begun to resume. We will be monitoring for any further issues.
Posted Oct 04, 2022 - 16:55 PDT
Update
Sectigo has confirmed that an infrastructure change on their end introduced the unintended change that caused this issue.

They are working on reverting the change to resolve this.

We will provide more details as they become available.
Posted Oct 04, 2022 - 13:45 PDT
Identified
We have escalated the matter with the Sectigo support team to address the connectivity problems between Enom and Sectigo servers which have been identified as the root cause of the outage on our end. We will post more details as we hear from them.
Posted Oct 04, 2022 - 12:01 PDT
Investigating
We are currently investigating reports of errors when submitting CSRs to Sectigo through our UI or API. The error received is "unable to retrieve CSR information when submitting CSR."
We have reached out to our operations team for assistance with this error. We will update you as soon as new info becomes available. Thank you.
Posted Oct 04, 2022 - 10:17 PDT
This incident affected: SSL Certificates.