.TW Registry
Incident Report for Enom
Resolved
The service has been completely restored. If you are still experiencing issues, please don't hesitate to contact us!
Posted Apr 19, 2019 - 16:52 PDT
Monitoring
Our connection to .TW is restored and we are now monitoring for stability.
Posted Apr 19, 2019 - 12:32 PDT
Investigating
We are currently investigating a disconnection from the .TW registry. During this period the following services may be degraded or unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates
Posted Apr 19, 2019 - 11:40 PDT
This incident affected: Domain Services (Other ccTLDs).