Basic Email - Webmail login
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Nov 26, 2018 - 17:56 PST
Monitoring
We were able to identify and resolve the issues impacting the ability to sign into and access webmail.

As this has impacted services for some time today we will continue to monitor the stability of webmail to ensure there are no recurrences of these issues.
Posted Nov 26, 2018 - 15:10 PST
Update
We continue to work on resolving the identified issue which has been impacting the ability to log into and navigate Webmail.

We will continue updating this page as we keep on working on solving this issue.
Posted Nov 26, 2018 - 12:32 PST
Investigating
It has been brought to our attention that Webmail login for our Basic Email service has begun to fail again. We are working on isolating the issue and will give more information shortly.

Please be advised that Basic Email accounts can still be accessed via IMAP & POP connections, you will be able to send and receive emails using email software and configured accounts on mobile devices.
Posted Nov 26, 2018 - 11:47 PST
This incident affected: Basic Email Service.