.ca Registry
Incident Report for Enom
Resolved
Our connection to .CA is back up and running.
Posted Mar 20, 2020 - 04:50 PDT
Investigating
We are experiencing connections to be down for the .CA TLD. We are in contact with the registry to resolve this issue.
Posted Mar 19, 2020 - 20:59 PDT
This incident affected: Domain Services (Core ccTLDs).