Enom Operation Timeout Error
Incident Report for Enom
Resolved
Our operations team was able to identify and resolve the issue.

Thank you for your patience.
Posted May 19, 2020 - 04:38 PDT
Investigating
We are currently investigating an issue where users are getting the following error: "Operation has timed out!" when attempting to submit an order or account refill. Users may see this error but the orders or refills may still go through when refreshing and checking the account's order history under "My Reports". Our dev team is currently trying to identify the issue and work on a fix.
Posted May 18, 2020 - 16:00 PDT
This incident affected: Enom.com (Domain Purchase).