.Okinawa and .Tokyo TLDs
Incident Report for Enom
Resolved
Our connections have been restored. This incident is resolved.
Posted Sep 17, 2020 - 10:37 PDT
Update
We are currently experiencing connection issues with the .Okinawa and .Tokyo TLDs. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .Okinawa and .Tokyo domains. Existing domains will continue to resolve normally.
Posted Sep 16, 2020 - 21:03 PDT
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted Sep 16, 2020 - 21:02 PDT
This incident affected: Enom.com (Domain Search, Domain Purchase, Domain Management).