.TW Registry Connection Issue
Incident Report for Enom
Resolved
We have restored our connection with the .tw registry. Customers should once again be able to purchase and manage their .tw domains.
Posted Jan 10, 2021 - 13:54 PST
Investigating
We are currently experiencing connection issues with the .tw registry. During this time customers may have issues registering, updating, or renewing their .tw domains. We appreciate your patience as we investigate further with our dev team.
Posted Jan 10, 2021 - 11:31 PST
This incident affected: Domain Services (Other ccTLDs).