Webmail Login Issues
Incident Report for Enom
Resolved
This has been resolved.
Posted Mar 20, 2020 - 13:24 PDT
Monitoring
A resolution has been implemented and we have not received any new reports. We will continue to monitor.
Posted Mar 20, 2020 - 12:59 PDT
Investigating
We are currently investigating an issue where some users are unable to log into their Webmail or connect via IMAP. We will provide further updates as they are available.

Thank you for your patience.
Posted Mar 20, 2020 - 12:33 PDT
This incident affected: Basic Email Service.