Access.enom.com Google Domains Management Issue
Incident Report for Enom
Resolved
This issue is being addressed by our account manager. Please contact support if you run into any further issues.
Posted Sep 18, 2018 - 13:22 PDT
Investigating
We are currently looking into a case where domains registered through G-suite are not being given proper access passwords to log into access.enom.com and are not displaying the correct registrant information.

Thank you for your patience on this matter while we look into this case further.
Posted Sep 17, 2018 - 12:59 PDT
This incident affected: Domain Services (Core gTLDs).