Error when attempting to create a new Enom account
Incident Report for Enom
Resolved
The Error on the Create an Account page has been corrected. No further errors should appear when creating an account.
Posted Aug 16, 2017 - 16:10 PDT
Investigating
We are currently aware of an error in the Create an Account page at Enom.com. Our we have engaged the appropriate teams to resolve the issue.

Symptom: Clicking Sign Up Now after filling in account information returns an error page with the message "An Error has occurred"

We confirm that despite the error being displayed, the account has been created successfully. If you encounter this error after clicking Sign Up Now, go to http://www.enom.com and log in using the credentials you signed up with to complete your account setup.
Posted Aug 16, 2017 - 15:24 PDT