Webmail Connection Issues
Incident Report for Enom
Resolved
We have resolved the issues with Webmail. Thank you for your patience.
Posted 3 days ago. Sep 12, 2019 - 10:06 PDT
Investigating
We're currently investigating reports that some users are experiencing intermittent connection issues when attempting to access webmail via mail.enom.com. There may be some degradation on our mail servers.

We appreciate your patience, while we investigate this issue further.
Posted 3 days ago. Sep 12, 2019 - 09:29 PDT
This incident affected: Basic Email Service.