.tw Registry Connection Issues
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Mar 06, 2021 - 21:49 PST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2021 - 20:29 PST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2021 - 20:05 PST
Investigating
We are currently seeing registry connection issues for .tw During this time customers may have issues with registrations, renewals, and lookups. We hope to have a fix soon.
Posted Mar 05, 2021 - 20:54 PST
This incident affected: Domain Services (Core ccTLDs).