Okinawa TLD Connection
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 19:56 PDT
Investigating
We are currently experiencing connection issues with the .Okinawa TLD. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .Okinawa domains. Existing domains will continue to resolve normally.
Posted Sep 16, 2020 - 17:55 PDT
This incident affected: Enom.com (Domain Search, Domain Purchase, Domain Management).