Credit Card Management unavailable due to unscheduled maintenance
Incident Report for Enom
Resolved
Credit Card Management pages are now resolved. All credit card management pages are now resolving correctly.
Posted Jan 16, 2018 - 13:14 PST
Investigating
Due to an unscheduled maintenance, pages that contain credit card information, such as the Account Settings, Account Refill, and Order Checkout page are resolving to the Enom Outage page. We are investigating the cause of the issue and are working towards a solution as quickly as possible.
Posted Jan 16, 2018 - 12:23 PST