Order processing delays
Incident Report for Enom
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 04, 2019 - 19:40 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Apr 04, 2019 - 17:25 PDT
Investigating
Due to an upstream vendor issue, you may experience a delay in order processing times. This could affect orders paid by credit card or account balance, of any order type. We're monitoring closely for any updates from the vendor and will keep you posted.
Posted 2 months ago. Apr 04, 2019 - 13:31 PDT
This incident affected: Enom.com (Domain Purchase).