Domain Provision Delays
Incident Report for Enom
Resolved
This issue has been resolved.
Posted Jun 19, 2020 - 12:07 PDT
Monitoring
Our Operations team has resolved the provision delay and we will continue to monitor for any further reports.
Posted Jun 19, 2020 - 09:29 PDT
Investigating
We are investigating reports of domain provision delays. Customers may be unable to see domains via their registered list for up to 1 hour after processing a registration, push or transfer completion.

While we investigate, please use the search bar function found at the top right of your account and set it to 'manage' to load domain details.

Thank you for your patience.
Posted Jun 19, 2020 - 08:56 PDT