Chat Maintenance
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Nov 13, 2021 - 19:07 PST
Monitoring
Chat customers will experience a maximum service disruption of 45 minutes at some time within the 1-hour maintenance window between 6pm-7pm pst
Posted Nov 13, 2021 - 19:06 PST
This incident affected: Customer Support.