CM Registry
Incident Report for Enom
Resolved
Our dev team has now fully confirmed that the connection is stable and transactions are being completed successfully.

Thank you for your patience with this issue.
Posted Nov 12, 2018 - 09:53 PST
Monitoring
The .CM registry is no longer experiencing an outage and we are now monitoring our connection for stability.
Posted Nov 09, 2018 - 06:42 PST
Identified
We continue to work with the .cm registry as they work to resolve their connectivity issues. We will update you as any new information becomes available.
Posted Nov 06, 2018 - 23:53 PST
Investigating
We are experiencing issues with our connection to the .CM registry. This affects the following aspects of domain management:

Availability Checks,
Whois Services,
Domain Purchases,
Domain Renewals,
Domain Updates,

DNS may continue to resolve, but changes will be unavailable at this time.
Posted Nov 06, 2018 - 01:30 PST