Phone Support - Upstream Provider Outage
Incident Report for Enom
Resolved
Service has been restored and phone support is fully functional again. Closing this incident.
Posted Jan 13, 2021 - 15:45 PST
Investigating
Due to an issue with one of our upstream providers we are experiencing issues with receiving calls, please use alternative means of contacting support by reaching out through our chat widget on enom.com or emailing [email protected] for assistance.
Posted Jan 13, 2021 - 14:29 PST
This incident affected: Customer Support.