Enom Webmail Login Issues
Incident Report for Enom
Resolved
No further reports have come in. This issue has been resolved. Thank you for your patience.
Posted Mar 18, 2020 - 12:58 PDT
Monitoring
We have resolved the issue and services have been restored. We will continue to monitor the situation.
Posted Mar 18, 2020 - 11:50 PDT
Investigating
We are currently investigating an issue where some Enom webmail users are unable to login and access their webmail. We thank you for your patience as we look into this issue further and work to get this resolved.
Posted Mar 18, 2020 - 09:44 PDT
This incident affected: Basic Email Service.