Website order processing timeouts and credit card failures
Incident Report for Enom
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 03, 2019 - 17:33 PST
Monitoring
Our team is reporting that they were able to identify the problem and have implemented a fix. Orders should now be processing as normal. Please reach out to support if you run into any further issues as we continue to monitor this case.

Thank you for your patience on this matter.
Posted 6 months ago. Jan 03, 2019 - 11:08 PST
Update
Some customers are also reporting pre-authorization errors manifesting during Credit Card updates, or "Declined" messages when they know their payment method is valid, which may also be related to this issue.
Posted 6 months ago. Jan 03, 2019 - 10:05 PST
Investigating
We are currently investigating reports of timeouts when loading pages or putting orders through on Enom.com, EnomCentral.com, and BulkRegister.com. Our team is still looking into the cause and we'll continue to update you on our progress.
Posted 6 months ago. Jan 03, 2019 - 09:42 PST
This incident affected: Enom.com (Website, Domain Purchase).