Enom DNS Delays
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Aug 04, 2022 - 18:47 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2022 - 18:00 PDT
Investigating
We have discovered a potential delay in updates on our DNS hosts (name-services.com). We've engaged our operations staff to investigate further.

Record adjustments may take longer than usual to update.
Posted Aug 04, 2022 - 14:56 PDT
This incident affected: DNS Service.