Update - We are still investigating this issue and we will provide further updates on our status page as soon as new information becomes available.
Thank you for your patience and understanding.

Apr 25, 2024 - 15:02 PDT
Update - We are still investigating this issue, We will provide further updates on our status page as soon as new information becomes available. Thank you for your patience and understanding.
Apr 25, 2024 - 11:53 PDT
Investigating - We're currently experiencing issues with webmail being slow/unresponsive, also impacting login. Our engineers are investigating this issue and will post updates as they become available.
Apr 25, 2024 - 09:05 PDT
Domain Services Operational
Core gTLDs ? Operational
Core ccTLDs ? Operational
Other gTLDs ? Operational
Other ccTLDs ? Operational
API Operational
Basic Email Service Degraded Performance
G Suite Email Service Operational
DNS Service Operational
Web Hosting Service Operational
SSL Certificates Operational
Enom.com Operational
Website Operational
Domain Search Operational
Domain Purchase Operational
Domain Management Operational
Customer Support ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
.NL Registry Maintenance Apr 30, 2024 01:00-04:00 PDT
During this scheduled system maintenance, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart

Posted on Apr 25, 2024 - 08:54 PDT
Identity Digital Registry Maintenance May 6, 2024 15:00-17:00 PDT
During this scheduled system maintenance, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart

Posted on Apr 25, 2024 - 08:14 PDT
.ORG Registry Maintenance May 7, 2024 10:00-12:00 PDT
During this scheduled system maintenance, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart

Posted on Apr 25, 2024 - 08:17 PDT
.CH Registry Maintenance May 16, 2024 22:00-22:30 PDT
During this scheduled system maintenance, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart

Posted on Apr 25, 2024 - 08:26 PDT
.COM, .NET Registry Maintenance May 19, 2024 18:00-18:45 PDT
During this scheduled system maintenance, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart

Posted on Apr 25, 2024 - 08:29 PDT
.EU Registry Maintenance May 29, 2024 22:00 - May 30, 2024 01:00 PDT
During this scheduled system maintenance, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart

Posted on Apr 25, 2024 - 08:51 PDT
.CH Registry Maintenance Jun 6, 2024 22:00-22:30 PDT
During this scheduled system maintenance, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart

Posted on Apr 25, 2024 - 08:43 PDT
Past Incidents
Apr 25, 2024

Unresolved incident: Webmail Login.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024

No incidents reported.

Apr 20, 2024
Completed - The scheduled maintenance has been completed.
Apr 20, 18:11 PDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 20, 17:11 PDT
Scheduled - Sectigo is undergoing scheduled maintenance. This may affect all Sectigo products and services.

Affected services:
Sectigo Portal
Sectigo API
Order placement
Order Reissuing

This maintenance is expected to last 2 hours after which regular service will resume

Apr 20, 17:10 PDT
Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.