Basic Email Service
Incident Report for Enom
Resolved
We've been monitoring our fix for the earlier hosted email issues, and our service is now fully restored and stable. Thanks for sitting through this one!
Posted 5 days ago. Mar 15, 2019 - 10:44 PDT
Monitoring
We believe we have repaired the issue causing connectivity issues for our hosted email customers. A fix is in place, and we are monitoring the results.
Posted 5 days ago. Mar 15, 2019 - 09:27 PDT
Investigating
Our operations team is working to address an issue with our Basic Email Service. During this time, Webmail, IMAP/POP connections and incoming/outgoing mail may be affected.

We will provide an update once we have additional information.
Posted 5 days ago. Mar 15, 2019 - 08:32 PDT
This incident affected: Basic Email Service.