HostedEmail
Incident Report for Enom
Postmortem

On November 16, 2021, at 3:14 AM PT, The hosted email platform experienced service interruption, causing inbound email delays and intermittently impacting webmail..

At 12:00 PM PT, The engineering team increased spam resources to better process the increased backlog of inbound emails and restarted AAA nodes to alleviate the high load to stabilize the hosted email environment.

The root cause is still under investigation; however, the engineering team was able to identify a malfunctioned process in the legacy Hosted Email platform that caused the Authentication nodes to high load. As a result, the Authentication node impacted, Spam filtering and Inbound mail nodes, forcing email to queue up and reducing email delivery volume.

The engineering team is to continue investigating the root cause. In addition, we have increased the Hosted Email Spam filtering and Authentication nodes to address the load concerns as a preventative measure.

We are committed to completing the hosted email migration into the new cloud before the end of the year to maintain a scalable and stable hosted email.

Thank you,

The Engineering Team

Posted Nov 19, 2021 - 07:12 PST

Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 17:42 PST
Monitoring
A fix has been implemented by our engineering team and emails are beginning to be received in a timely manner. We are continuing the monitor the results.

Thank you for your continued patience.
Posted Nov 16, 2021 - 12:44 PST
Identified
Our team is still currently working on this issue. Customers still may see some delays with inbound emails.
Posted Nov 16, 2021 - 05:16 PST
Investigating
We are currently experiencing an issue with our HostedEmail service. Users may experience the errors such as, but not limited to, "Service unavailable - try again later" When attempting to send or receive mail. Our engineering team is aware and working on the problem
Posted Nov 16, 2021 - 04:15 PST
This incident affected: Basic Email Service.